Epf en linux 64 bits


El Eclipse Process Framework es un marco de trabajo para definir modelos de procesos de ingeniería de software (Tiene modelos predefinidos personalizables para OpenUP, Scrum, XP y Togaf). La literatura al respecto es laaaarga e interesante, EPF ofrece una herramienta para acompañar el proceso de definición y publicación de los modelos llamado “Eclipse Process Framework Composer”, para ejecutar correctamente esta herramienta en un entorno Ubuntu de 64 bits es necesario:

  1. Instalar librerias de 32 bits y la jvm de 32 bits, desde consola:
    #sudo apt-get install ia32-libs ia32-sun-java6-bin
  2. Crear las variables de entorno, desde consola:
    #gedit ~/.profile
    --en gedit
    export MOZILLA_FIVE_HOME="/usr/lib/firefox"
    export LD_LIBRARY_PATH="$MOZILLA_FIVE_HOME:$LD_LIBRARY_PATH"
  3. Finalmente iniciar el Epf composer apuntando a la jvm de 32 bits, desde consola:
    #./epf -vm /usr/lib/jvm/ia32-java-6-sun/bin

Espero que sea de ayuda para quienes quieran usar una buena herramienta para especificar y socializar su proceso de ingeniería de software.

Acerca de Nickman

Aunque crítico e Ingeniero (especializado en software), piloto de aeroplano soy (seré).

2 pensamientos en “Epf en linux 64 bits

  1. Saludos,

    Estoy intentando correr el epf composer en ubuntu 10.10 de 64bits, ya ejecute las instrucciones indicadas, pero me marca error al cargar el archivo ‘/usr/lib/gio/modules/libgvfsdbus.so’.

    Pese a esto el EPF se ejecuta, pero al momento de abrir cualquier elemento marca el siguiente error:

    A system error has occurred. Click Details for more information.

    Close some of the opened editors and try again.
    No more handles [MOZILLA_FIVE_HOME=’/usr/lib/firefox’] (java.lang.UnsatisfiedLinkError: no swt-mozilla-gtk-3550 or swt-mozilla-gtk in swt.library.path, java.library.path or the jar file)

    Alguna idea de que es lo que tengo que hacer para que corra sin problemas.

    Efraín.

  2. No he probado mucho el framework (apenas tengo un par de días estudiandolo), pero las instrucciones parecen funcionar perfecto con la última versión disponible de EPF (epf-composer-1.5.1.4_20120423_0500-linux). Muchas gracias por la información.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s